Скомпилирован с несовместимой версией -- eclipse поле с участием scala поле с участием m2eclipse поле с участием m2e поле с участием scala-ide пол Связанный проблема

Cross-compiled with an incompatible version


0
vote

проблема

русский

Я использую Eclipse с помощью <div> 10602 - MS21075L3N - NUTPLATE </td> <td> <select name="icon_00002"> <option/> <option value="ARM">As Removed</option> <option value="INP">Inspected&#47; Tested</option> <option value="NES">New Surplus</option> <option value="NEW" selected>New</option> <option value="OVH">Overhauled&#47; Remanufactured</option> <option value="RPR">Repaired&#47; Serviceable</option> <option value="UNK">Unknown</option> </select> </td> <td> Current&nbsp;Created<br/> </td> <td class="align-text" valign="top" nowrap="nowrap"> Ordered&nbsp;1&nbsp;&nbsp;<br/> Cancelled:&nbsp;0&nbsp;&nbsp;<br/> Remaining:&nbsp;1&nbsp;&nbsp;<br/> </td> <td class="align-text" valign="top" nowrap="nowrap"> <input type="text" size="8" name="ipm_00002" value="100"/> &nbsp;<input type="checkbox" name="opm_00002" value="Y"/> </td> <td>&nbsp;</td> <td class="align-text" valign="top" nowrap="nowrap"> 0 Plugin. В настоящее время я получаю следующее сообщение об ошибке:

<Код> <div> 10602 - MS21075L3N - NUTPLATE </td> <td> <select name="icon_00002"> <option/> <option value="ARM">As Removed</option> <option value="INP">Inspected&#47; Tested</option> <option value="NES">New Surplus</option> <option value="NEW" selected>New</option> <option value="OVH">Overhauled&#47; Remanufactured</option> <option value="RPR">Repaired&#47; Serviceable</option> <option value="UNK">Unknown</option> </select> </td> <td> Current&nbsp;Created<br/> </td> <td class="align-text" valign="top" nowrap="nowrap"> Ordered&nbsp;1&nbsp;&nbsp;<br/> Cancelled:&nbsp;0&nbsp;&nbsp;<br/> Remaining:&nbsp;1&nbsp;&nbsp;<br/> </td> <td class="align-text" valign="top" nowrap="nowrap"> <input type="text" size="8" name="ipm_00002" value="100"/> &nbsp;<input type="checkbox" name="opm_00002" value="Y"/> </td> <td>&nbsp;</td> <td class="align-text" valign="top" nowrap="nowrap"> 1

Похоже, что версии извлеченной Scala и Scala IDE Match. Я просто хотел убедиться, что это a "Ложно-отрицательный" Как описано здесь и может быть безопасно выключено.

Английский оригинал

I am using eclipse with m2eclipse-scala plugin. Currently, I get the following error message:

exampleA_2.10-2.0.1.jar of module build path is cross-compiled with an incompatible version of Scala (2.10.0). In case this report is mistaken, this check can be disabled in the compiler preference page

It looks like the versions of extracted Scala and Scala IDE match. I just wanted to make sure that this is a "false-negative" as described here and can be safely turned off.

</div
              
   
   

Список ответов

0
 
vote
vote
Лучший ответ
 
<Р> Как @The Архетипический Павел предложил, это потому, что я использовал неправильную библиотеку Scala. <Р> Если вы используете Scala 2.11 (проверка на <код> About Scala IDE -> installation details ), вы можете понизить, следуя инструкции . Это намного проще, чем удалить и заново установить Scala IDE другие сообщения StackOverflow рекомендуем.
 

As @The Archetypal Paul suggested, it was because I was using wrong Scala library.

If you are using Scala 2.11 (check at About Scala IDE -> installation details), you can downgrade by following instruction here. It's a lot easier than uninstalling and re-installing Scala IDE as other Stackoverflow posts recommend.

</div
 
 
0
 
vote
<Р> Я также столкнулся с тем же проблемным & GT; Я пытаюсь использовать Касба банку в Скале для интеграции с MongoDB. <Р> После анализа проблемы я обнаружил, что - & GT; я пытаюсь использовать касбы 2.9.1 версии и моя версия Scala 2.11.8 <Р> Root-Причина такой ошибки: ваша баночка компилируется в 2.9.0 версии, и вы используете 2.11.8 версии Scala <Р> Итак, решимостью, что я использую банку, который скомпилирован в 2,11 версии - лестницу

 <код> <groupId>org.mongodb</groupId> <artifactId>casbah-core_2.11</artifactId> <version>3.1.1</version>   

 

I also faced the same issue-> I am trying to use casbah jar in scala to integrate with mongodb.

After analyzing the problem i found that -> i am trying to use casbah 2.9.1 version and my scala version is 2.11.8

Root-Cause of such error is : your jar is compiled in 2.9.0 version and you are using scala 2.11.8 version

So, to resolve that i use the jar that is compiled into 2.11 scala version-

<groupId>org.mongodb</groupId> <artifactId>casbah-core_2.11</artifactId> <version>3.1.1</version> 

</div
 
 
0
 
vote
<Р> Я столкнулся аналогичные проблемы в Eclipse IDE, где я построил SCALA проект Спарк в Maven. Версия Scala была установлена ​​в 2.11. Позже я модернизировал Scala-Ide плагин в Eclipse, после чего мой проект отмечен ниже ошибки, <Р> exampleA_2.10-2.0.1.jar траектории модуль сборки кросс-скомпилирован с несовместимой версией Scala (2.10.0). В случае, если этот отчет ошибается, эта проверка может быть отключена на странице предпочтений компилятора

Щелкните правой кнопкой мыши папку проекта и Гт & GT Scala; комплект Scala версия. Вот моя версия Scala отображается как 2,10. Я выбрал 2.11 и удалить все сообщения об ошибках.

 

I was facing similar issue in Eclipse IDE where I had built a Spark scala project in Maven. The scala version was set to 2.11. Later, I upgraded Scala-Ide plugin in Eclipse after which my project marked below errors,

exampleA_2.10-2.0.1.jar of module build path is cross-compiled with an incompatible version of Scala (2.10.0). In case this report is mistaken, this check can be disabled in the compiler preference page

Right click project folder > scala > set scala version. Here my scala version was displayed as 2.10. I selected 2.11 and removed all the error messages.

</div
 
 

Связанный проблема

0  Как удалить нынешние barchart (jfreechart), отображаемый и отображаю новый Barchart в том же представлении плагина Eclipse RCP?  ( How to delete the present barchartjfreechart displayed and display new barchar ) 
Я создаю Barchart с видом на плагин RCP. Данные, которые будут отображаться на графике, поставляется из файла базы данных SQLite3. Код, который я написал, ото...

1  Eclipse Indigo не начнется в Windows 7  ( Eclipse indigo wont start in windows 7 ) 
Eclipse Indigo не запускается в Windows 7 (первый запуск), появляется экран Splash, остается там, и впоследствии ничего не происходит. Пока я попробовал сле...

3  Eclipse Java Formatter - новая линия до закрытия скобок  ( Eclipse java formatter newline before closing parentheses ) 
Можно ли настроить Dippleter Eclipse Java для вставки новой строки до закрытия скобок выражений, деклараций метода и вызовы методов? Обратите внимание на же...

1  org.osgi.service.aplication.ApplicationException: нет идентификатора приложения не найден. Ошибка при запуске C Eclipse в системе Windows XP  ( Org osgi service application applicationexception no application id has been fo ) 
Я сталкиваюсь с org.osgi.service.Application.ApplicationException: нет идентификатора приложения, ошибка при запуске C ++ Eclipse в системе Windows XP. Может ...

0  Автоматически заканчивать приложение / или автоматическое уничтожение приложения, поставляемое в Android?  ( Automatically finish an app or auto destroy app posible in android ) 
Два вопроса: 1) Я хочу добавить к моему приложению возможность автоматически выхода через несколько минут бездействия. Что я подразумеваю под автоматическим в...

0  Я не мог импортировать «существующие проекты Maven» i-Jetty  ( I couldnt import existing maven projects of i jetty ) 
Они сказали , CD $ IJETTY_HOME / COUSOLE MVN Чистая установка Это даст файл войны в $ ijetty_home / console / webapp / target, а также apk в $ ijetty_h...

5  Как удалить дополнительный класс выпадают в Eclipse Project Explorer View?  ( How to remove additional class drop down in eclipse project explorer view ) 
В представлении проводника проекта Eclipse Luna, есть дополнительные выпадающие файлы для Java, которые представляют класс внутри файла (значок зеленого цв...

3  Из ошибки памяти начать JBoss с порталом из Eclipse  ( Out of memory error starting jboss with portal from eclipse ) 
Я не могу получить портал jboss, чтобы начать с Eclipse, хотя, как только начинается нормально, а портал также начинается, а также начинается с командной стро...

0  Java нерешенная переменная JPanel?  ( Java unresolved jpanel variable ) 
Почему не может <код> aniPanel быть разрешена в переменной. Я пробовал <код> AniPanel aniPanel = new AniPanel(); Но это не решает проблему. Я также по...

4  Весенние ботинки, весенние загружены, Eclipse, Maven Основной пример  ( Spring boot spring loaded eclipse maven basic example ) 
Я обнаружил, что основной пример настройки весеннего ботинка с загрузкой пружины не работает в соответствии с документацией. Я следовал инструкциям на http :...

1  Первое приложение для Android после Eclipse Установить  ( First app for android after eclipse install ) 
Я искал вокруг и не могу найти точную ситуацию или ответить, что мне нужно, поэтому мне придется задать вопрос, что я уверен, что где-то просил там, поэтому м...

23  Ошибка пропуска тестового прогона: запуск приборов не удалось из-за «Java.lang.classnotfoundException»  ( Test run failed instrumentation run failed due to java lang classnotfoundexcep ) 
Это мой первый раз настроив проект теста на Android для проверки проекта Android. Я создал очень базовый тестовый случай, который я пытаюсь запустить, однак...

1  Eclipse IDE отключается часто  ( Eclipse ide shuts down frequently ) 
Я пытался использовать SDK SDK SDK 22.3.0-887826, чтобы узнать о Develeopment Android, однако IDE отключается часто. Это происходит много, но в основном при и...

1  Установка поля _ID с использованием SQLite & ContentProvider в Android  ( Setting the id field using sqlite contentprovider in android ) 
Я пытаюсь настроить ContentProvider в приложении Android, чтобы держать информацию о домах. Я хотел бы иметь возможность установить поле _id, чтобы быть таким...

0  Eclipse найти исходный файл из библиотеки  ( Eclipse find source file from library ) 
Для отладки его часто полезно читать исходный код библиотеки. При указывании на функцию библиотеки, которую я хочу проверить и открывать контекстное меню, и щ...

Связанный проблема

0  Как удалить нынешние barchart (jfreechart), отображаемый и отображаю новый Barchart в том же представлении плагина Eclipse RCP? 
1  Eclipse Indigo не начнется в Windows 7 
3  Eclipse Java Formatter - новая линия до закрытия скобок 
1  org.osgi.service.aplication.ApplicationException: нет идентификатора приложения не найден. Ошибка при запуске C Eclipse в системе Windows XP 
0  Автоматически заканчивать приложение / или автоматическое уничтожение приложения, поставляемое в Android? 
0  Я не мог импортировать «существующие проекты Maven» i-Jetty 
5  Как удалить дополнительный класс выпадают в Eclipse Project Explorer View? 
3  Из ошибки памяти начать JBoss с порталом из Eclipse 
0  Java нерешенная переменная JPanel? 
4  Весенние ботинки, весенние загружены, Eclipse, Maven Основной пример 
1  Первое приложение для Android после Eclipse Установить 
23  Ошибка пропуска тестового прогона: запуск приборов не удалось из-за «Java.lang.classnotfoundException» 
1  Eclipse IDE отключается часто 
1  Установка поля _ID с использованием SQLite & ContentProvider в Android 
0  Eclipse найти исходный файл из библиотеки 



© 2021 www.qaru.top All Rights Reserved. Q&A House все права защищены


Licensed under cc by-sa 3.0 with attribution required.